Over 10 years we helping companies reach their financial and branding goals. Onum is a values-driven SEO agency dedicated.

CONTACTS
Noticias

La versión de mantenimiento de WordPress 6.4.1 corrige errores en la versión 6.4


WordPress lanzó una versión de mantenimiento el miércoles por la noche para solucionar los problemas descubiertos poco después de que WordPress 6.4 fuera lanzado al público el martes 7 de noviembre.

Dos de los problemas eran algo serios porque afectaban el funcionamiento de ciertos complementos y podían causar problemas a los sitios que encontraban cualquiera de los dos problemas.

El tercero fue un error tipográfico que resultó en un aviso mal configurado en el panel de administración.

Tres problemas solucionados

  1. Error de tipografía
  2. El código eliminado causó problemas de compatibilidad con versiones anteriores
  3. Un error crítico hace que la descarga falle

Error tipográfico en el código: problema cosmético menor

El problema del error tipográfico fue relativamente menor. Afectó la forma en que aparecía una pantalla molesta en el panel de administrador, haciendo que se extendiera por la parte superior de la página.

Antes de la solución:

La versión de mantenimiento de WordPress 6.4.1 corrige errores en la versión 6.4La versión de mantenimiento de WordPress 6.4.1 corrige errores en la versión 6.4

Después de la solución:

La versión de mantenimiento de WordPress 6.4.1 corrige errores en la versión 6.4La versión de mantenimiento de WordPress 6.4.1 corrige errores en la versión 6.4

Error de compatibilidad con versiones anteriores

Este error fue una de esas cosas aleatorias que no siempre se pueden explicar.

Lo que sucedió es que los contribuyentes principales eliminaron el código que el núcleo de WordPress ya no usaba, por lo que se suponía que era seguro eliminarlo.

Pero… ese código todavía estaba siendo utilizado por los complementos y como ahora faltaba, WP 6.4 aparentemente estaba provocando que esos complementos se rompieran.

Entonces, la solución que se encuentra en esta versión de mantenimiento es volver a agregarla.

Error crítico que causa un error de cURL

La última solución fue para un error que provocaba que fallara la descarga de actualizaciones y mostrara un mensaje de error que decía que se había agotado el tiempo de espera, error de cURL 28: Se agotó el tiempo de espera de la operación.

Según la discusión interna de WordPress sobre cómo solucionar este problema:

“Esta cuestión debería ser crítica.

6.4 actualizó la versión de la biblioteca de Solicitudes que incluyó un cambio importante para cualquiera que ejecute en un host con la versión 7.29 de curl (al menos)”.

Este problema también fue otra de esas cosas aleatorias. En este caso, se trataba de servidores que utilizaban una versión anterior y desactualizada de la biblioteca cURL (cURL 7.29). La última versión de cURL es 8.4.0.

Llevar

WordPress lanza versiones de prueba de WordPress para que la comunidad las pruebe e informe cualquier error.

Pero si nadie los experimenta, aparecen cuando se lanza la versión final y eso es lo que sucedió.

La versión original de WordPress 6.4 que actualiza esta nueva versión de mantenimiento tenía el nombre en código Shirley.

La nueva versión de mantenimiento pide un nombre en clave No me llames Shirley.

hola@juanrecio.com

Author

hola@juanrecio.com